ちょっとした覚書に。
by dipus
S M T W T F S
1 2 3 4 5 6
7 8 9 10 11 12 13
14 15 16 17 18 19 20
21 22 23 24 25 26 27
28 29 30 31
タグ
カテゴリ
全体
Zaurus
Emacs
Palm
Apple
Unix
OpenBSD
GR Digital
Book
Complaint
Private
WM
Zaurus(IPK)
Kinesis
HSDPA
NetWalker
iPhone
以前の記事
2010年 02月
2009年 09月
2009年 07月
2009年 03月
2009年 02月
2009年 01月
2008年 09月
2008年 08月
2008年 07月
2008年 06月
2008年 05月
2008年 04月
2008年 03月
2008年 02月
2008年 01月
2007年 12月
2007年 11月
2007年 10月
2007年 09月
2007年 08月
2007年 07月
2007年 06月
2007年 05月
2007年 04月
2007年 03月
2007年 02月
2007年 01月
2006年 12月
2006年 11月
2006年 10月
2006年 09月
2006年 08月
2006年 07月
2006年 06月
2006年 05月
2006年 04月
2006年 03月
2006年 02月
2006年 01月
2005年 12月
2005年 11月
2005年 10月
2005年 09月
2005年 08月
2005年 07月
2005年 06月
2005年 05月
2005年 04月
2005年 03月
2005年 02月
2005年 01月
2004年 12月
2004年 11月
2004年 10月
2004年 09月
2004年 08月
2004年 07月
2004年 06月
2004年 05月
2004年 04月
最新のトラックバック
[Emacs][Zaur..
from ひとりぶろぐ
[Zaurus]Ruby..
from ひとりぶろぐ
OpenSSH の初期設定
from Masaatoshi Ito..
PostgreSQL
from Pukiwiki Plus!..
PostgreSQL
from Pukiwiki Plus!..
Gmail Bookを手..
from 魚輪事務業務日記 SAKAN..
[Zaurus] Rub..
from ひとりぶろぐ
Zaurus Ruby/..
from ひとりぶろぐ
Zaurus X/Qt-..
from MobileMemo Web..
ウィルコムの新しいW-Z..
from 激安情報でお得に購入計画.COM
検索
その他のジャンル
ファン
記事ランキング
ブログジャンル
画像一覧


タグ:Ruby ( 18 ) タグの人気記事

ruby, openssl

Ruby 1.8.7、OpenSSL 0.9.8h のパッケージングです。
OpenSSL に付随して OpenSSH 5.0p1 もリビルドしています。
[PR]
by dipus | 2008-06-03 21:38 | Zaurus(IPK)

Ruby 1.8.7 preview4

[ruby-dev:34462]で、ruby 1.8.7 preview2の公開アナウンスが流れていました。テスト用のパッケージを用意しました。
個人的にはRuby/Qteはほとんど使ってないのですが、Ruby/Qteのスクリプトが公開されているサイトでよく参照されているようですので、事前テスト用のパッケージです。
追記:
preview3に入れ替えました。
preview4に入れ替えました。
[PR]
by dipus | 2008-05-20 23:22 | Zaurus(IPK)

現実逃避に諸々を

ざっと思いつくままにパッケージの更新をしておきました。
Emacs はX11版とターミナル版の両方、Hyper Estraier は最新に追従したついでに、Rubyネイティブなパッケージも追加で作りました。Mew、emacs-w3mも最新に。lookup を最新にしたついでに放置していたeblookも同様に追従。
個人的には使う機会は少ないのですが、要望が上がっているので、Hyper Estraier の Ruby バインディング(ARMネイティブ)をパッケージにしています。使ってやってください。
また、X/Qt の中で Emacs を起動した状態だと、mlterm の中から gem install hogehoge なんか叩いた時は、ものによっては memory exhaust で X/Qt ごと落ちます。パッケージにはしていますが、使用は推奨しません。Zaurus で RubyGems を使うのはメモリの関係から自殺行為に等しいかもってことで、現在用意している Ruby バインディングは gems を使わずにクロスコンパイルしたものばかりです。個人的に Mew の中から使う可能性もある sqlite3-ruby も rubygems 経由ではなく、素でクロスコンパイルしたものを用意しています。

[PR]
by dipus | 2007-12-29 04:55 | Zaurus(IPK)

Ruby 1.8.6 p111

「net/httpsライブラリにおける「中間者によるなりすまし攻撃」に対する脆弱性について」で、ruby 1.8.6-p111, 1.8.5-p114 が公開されています。
脆弱性の詳細は、こちらを参照してください。
1.8.5系は用意しないと言いながらも、結局は公開しちゃってます。

[PR]
by dipus | 2007-10-04 15:13 | Zaurus(IPK)

諸々

Emacs は今まで通り CVS Head のパッケージングで行きます。それに付随して周りのパッケージもバージョンに依存するものは、Emacs 23.0.50 に合わせています。諸々アップデートしてください。
ただし、毎度のことですが、ipkg update && ipkg upgrade だと、パッケージ内のファイル構成の変更からゴミが出ることがあります。コマンドラインでアップデートかけている方は注意してください。
すっかり忘れていましたが、Ruby も 1.8.5 と 1.8.6 の最新版を用意しています。しかし、ザウルスではほとんどの方が 1.8.6 に移行していると思うので、次回から 1.8.5 は用意しないかもしれません(要望があれば用意します)。

[PR]
by dipus | 2007-10-03 00:05 | Zaurus(IPK)

当てずっぽう

Ruby 1.8.6-p36-2, 1.8.5-p52-2 を用意。
「system関数の挙動?」という話が出て、SEGV 引いているっぽかったので、試しに以前から気になっていた--enable-pthread を外してコンパイルしたものを用意。当てずっぽうだったのですが、ピンポイントでヒットしたみたいなので、入れ替えておきました。
本当は追い掛けなきゃダメなんでしょうけど、当分時間が取れそうにないです。

[PR]
by dipus | 2007-07-14 04:31 | Zaurus(IPK)

Ruby 1.8.6-p36, 1.8.5-p52

Ruby 1.8.5, 1.8.6 のアップデートが出ています。
パッケージを用意しましたので、スクリプトを公開されている開発者の方は確認をお願いします。

[PR]
by dipus | 2007-06-11 05:07 | Zaurus(IPK)

ruby-postgres

Postgres(Ruby extension library)で、undefined symbol: PQserverVersion とエラーを吐く件に関して、postgres.c で該当部分をコメントアウトして再度コンパイル。
動作検証、感謝です。> みやおさん

PostgreSQL 本体の方に関して、こんなエラー(initdbの方)が出るという話もあるのですが、手元じゃ問題ない気がします(検証不足なので確証なし)。LANG=ja でエラーが出る方は glibc-locale-ja-* がインストールされてないためのはず。

[PR]
by dipus | 2007-03-20 10:35 | Zaurus(IPK)

Ruby 1.8.6

1.8.6 のリリースです。
コンパイル時のオプションは、1.8.5 から変更していません。依存するライブラリは、OpenSSL 0.9.8e と Berkeley DB 4.2.52のふたつです。そのほかはスタティックに組み込んでいます。
そのほかオリジナルリリースの詳細は、変更点互換性情報からどうぞ。

なお、ザウルス向けに用意している拡張モジュールは、下記の通りです。
 - ruby-uconv
 - ruby-kakasi
 - ruby-sqlite3
 - ruby-postgres
 - rubygems
 - hyperestraier(本体内に)



(追記)
1.8.5-p?? のパッケージっていりますか?
希望者がないようでしたら、1.8系は1.8.6のみで行きますが。

[PR]
by dipus | 2007-03-13 11:49 | Zaurus(IPK)

PostgreSQL + Postgres/Ruby

(需要があるみたいなので)PostgreSQL 7.4.16 と ruby-postgres の最新スナップショットを用意してみました。しかし、個人的にはまず使うことがない PostgreSQL なので、実際の動作云々に関しては全くといっていいほど確認していません(というか、分かりません)。
とりあえず、irb で (require "postgres") => true と返ってくること程度のチェックだけです。
ちなみに、公開しているパッケージ群は、ごく一部を除いて全てクロスコンパイルしたものです。Emacs の構築にはターゲットデバイス(ザウルス)でのダンプが必須なので、クロスコンパイル+セルフの混在に相当するのかな。あと、screen はパッチの多さにめげてしまいセルフコンパイルで逃げたような気もしますが、既に忘却の彼方です。
このほか、Hyper Estraier 1.4.10 や GnuPG 1.4.7、anthy 8706(スナップショット)辺りも、最新に追従しています。
[PR]
by dipus | 2007-03-07 03:45 | Zaurus(IPK)